Friday, May 08, 2009

Using firebug on firefox 3.5 beta

I updated to Firefox 3.5 beta a while ago, and almost all extensions became incompatible. And today, I just couldn't avoid not using firebug (I had Firebug 1.3.3) , so decided to make it 'compatible'.

This is what I had to do:
  1. OSX, find the install.rdf file at ~/Library/Application Support/Firefox/profiles/xxxxxxx/firebug@software.joehewitt.com/install.rdf (On Windows, I guess it should be at C:/Documents & Settings/username/Local Settings/Application Data/Firefox/profiles/xxxxxxx/firebug@software.joehewitt.com/install.rdf )
  2. Find a node like 3.0.*
  3. Change the version number in the above node to to 3.5.*.
  4. Save the file, and restart Firefox. Firebug should now be active, and available for use!

Disclaimer:
Of course there might be something new in firefox3.5 that isn't compatible with Firebug1.3.3, so it might give u some unexpected errors. I've been using it for a while, and its alright at my end. But use it at your own risk :P
Post a Comment